Dienstag, 8. September 2009

Google-Bot führt JavaScript aus

Gut - den eingefleischten SEOs hier erzähle ich wohl nichts Neues mehr. Aber ich habe gerade durch Zufall festgestellt, dass die Google-Bots beim Indizieren von Websites manchmal wohl auch JavaScript-Code ausführen.

Beim Lesen eines Artikels auf ha.ckers.org bezüglich verschiedener Antispam-Schreibweisen von Mailadressen kam mir der Gedanke, doch mal die Standardverschlüsselung von Mailadressen von TYPO3 zu überprüfen. Statt der verlinkten Adresse in Klartext steht dort nur ein JavaScript, welches ausgeführt den eigentlichen Adresslink auftauchen lässt.

Folglich habe ich daraufhin mal eine bestimmte Adresse, von der ich wusste, dass sie im Impressum einer mir bekannten Seite steht, mit Google gesucht. Und siehe da: bereits auf der ersten Seite der SERPs finde ich besagtes Impressum. Schlimmer noch: im Beschreibungstext zum Link wird auch noch genau diese Mailadresse im Klartext ausgegeben.

Neugierig geworden musste ich gleich noch eine Adresse ausprobieren. Für Seiten, die ich damals nicht mit TYPO3 erstellt hatte, habe ich immer den Linkencoder vom Antispam e. V. benutzt, um Mailadressen zu verschlüsseln. Hier allerdings stelle ich fest: den Code führt Google offensichtlich nicht aus. Die Testadressen konnte ich nicht finden. Schön. Dann benutzen wir in Zukunft halt den. Erst einmal. Ich sollte das Thema mal im Auge behalten...


Update:
Ein paar Stunden später hatte ich den ersten Kommentar hierzu. Dabei habe ich festgestellt, dass ich Quatsch geschrieben habe. Unfassbar, aber der Anker-/Linktext steht unkodiert im Quelltext. Und die Adresse, die ich exemplarisch getestet hatte, wird sogar gar nicht verschlüsselt. Komisch. Die Seite habe ich selbst eingerichtet, und normalerweise ist die Antispam-Geschichte mit das Erste, was ich bei TYPO3 anschalte.

Das wird wohl einer meiner unterbelichteten Nachfolger der Optik wegen (anders kann ichs mir nicht erklären) wieder abgeschaltet haben.

Wie es scheint, führt der Googlebot doch keinen JS-Code aus. Zumindest nicht so. Ich nehme erstmal alles zurück und behaupte das Gegenteil :-)

Kommentare:

gb hat gesagt…

die Logik verstehe ich jetzt nicht - wenn der Text doch im Klartext angezeigt wird, aber nur der Link verschluesselt ist, ist doch die richtige eMail-Adresse noch immer zu lesen, auch von Robots: (schon oft gesehen, zB.:

senden Sie uns eine eMail an |a href="$VERSCHLUESSELTE-MAIL-ADRESSE"|eMail@pr0vider.tld|/a| .

das |a| bitte als < a> ohne Leertaste lesen ;)

oder habe ich da einen Denkfehler?

wagii hat gesagt…

Siehe Update im Artikel.

gb hat gesagt…

:)